打开老项目时,项目编译报错,原来是 ShareSDK 又在作妖了。网上找了下解决方法,设置为隐私协议适配版本就好。

方法1

app/build.gradle

MobSDK {
    ..
    spEdition "fp"
    ..
}

方法2

gradle.properties 添加一行

MobSDK.spEdition=FP

新的项目已经不集成 ShareSDK,而是直接接原生的第三方了,所以不会碰到这个问题。